Проект

Общее

Профиль

Общие вопросы по LibreOffice

  • Если я сохраняю документ или презентацию на карту памяти, чтобы работать на чужом компьютере, что делать, если там не окажется LibreOffice?

Для этих целей есть специальная версия Portable: ftp://ftp/SPO/LibreOffice/Portable/
Установщик этой версии просто создаст папку с носимой версией LibreOffice. Эту папку нужно скопировать на карту памяти и запускать прямо с неё.

  • Я открываю файл из приложения, но ничего не происходит.

Если какой-либо файл уже открыт в LibreOffice, то часто новые файлы открываются, но на заднем плане. Нужно кликнуть на соответствующий значок в панели задач и активировать открытое окно.

Это официально зарегистрированная ошибка LibreOffice под Windows.

  • В свойствах документа не указывается автор, почему?

Поскольку LibreOffice продукт кроссплатформенный, он не берёт информацию об авторе из операционной системы. Нужно заполнить параметры автора в меню «Сервис»→«Параметры» во вкладке «LibreOffice»→«Сведения о пользователе». Не обязательно заполнять все поля, но, как минимум, ФИО и организацию следует заполнить. Также рекомендуется заполнить и контактную информацию, такую как e-mail и телефон.

  • Периодически возникают проблемы с открытием файла: пустое окно, полосы на тексте, другие артефакты.
Скорее всего это ошибки драйвера OpenGL для конкретной видеокарты. У LibreOffice есть, так называемый, черный список видеокарт, для которых он отключает использование OpenGL. Если у карты проблемы, а её ещё нет в черном списке, то можно отключить вручную:
  • Зайти в меню «Сервис»→«Параметры...»
  • В разделе «LibreOffice»→«Вид» снять установленную опцию «Весь вывод при помощи OpenGL»
  • У меня сейчас файлы tiff (jpeg,gif, и.т.п.) открываются в LibreOffice Draw и с ними невозможно работать.

Программа LibreOffice Draw, это редактор векторной графики, и он предназначен для другого. Не следует назначать программы из пакета LibreOffice для открытия по умолчанию абсолютно всех типов документов. Тот же tiff лучше открывать просмотром фотографий Windows или другими просмотрщиками, специально предназначенными для этого.

  • Я загружаю документ на сайт или отправляю по электронной почте, но принимающая сторона не принимает формат ODF, как быть?

Специально для упрощенной отправки документа по электронной почте в LibreOffice есть пункт меню «Файл»→«Отправить»→«Эл. почтой как текст MS Word».

Если требуется преобразовать документ в формат Microsoft, то нужно сделать это с помощью команды меню «Файл»→«Сохранить как...» или «Файл»→«Сохранить копию...» и выбрать нужный тип файла. Разница между этими командами в том, что в первом случае Вы сохраните и будете продолжать редактировать файл уже с новым именем; Во втором случае, документ сохранится под новым именем, но Вы будете продолжать редактировать документ с прежним именем. Также, если Вы документ изменяли, то в первом случае документ будет считаться сохраненным, а во втором — нет.

Если изменение документа не предполагается, рекомендуется использовать формат PDF.

  • Я отправляю файл в формате MS Office, но всё равно у получателя возникают проблемы с его открытием. В каком вообще формате лучше сохранять файлы, чтобы избежать проблем совместимости?

В настоящий момент наибольшая совместимость с MS Office достигается в бинарных форматах (DOC, XLS и PPT). Можно обратить внимание, что команда «Файл»→«Отправить»→«Эл. почтой как текст MS Word» отправляет файл именно в таком формате.
Если файл не предназначен для внесения исправлений, его лучше всего отправлять в формате PDF/A. При этом, хорошей практикой является внедрение в PDF исходного текста в формате ODF, чтобы в дальнейшем его можно было открыть и изменить.

  • О совместной работе с MS Office, если он установлен на вашем компьютере

Если у вас на компьютере установлен MS Office, может так получиться, что часть документов открываются в MS Office, а другая часть - в LibreOffice. В этом случае Вы обязательно столкнётесь с проблемой, при попытке копирования данных из одного офиса в другой. Чтобы этих проблем не было, нужно открывать все документы в LbreOffice. Учтите, что не смотря на декларирование совместимости с Open Document, на деле MS Office поддерживает этот стандарт плохо, поэтому, для одновременной работы с документами в различных форматах, открывать их нужно именно в LibreOffice.
Особенно велика вероятность проблем при попытке открыть электронную таблицу в формате Open Document (.ods) в MS Office.

  • Как заставить работать макросы MS Office в LibreOffice?

В меню «Сервис»→«Параметры...» поставьте все галки в разделе «Загрузка/сохранение»→«Свойства VBA»
Эта опция позволяет использовать макросы MS Office в LibreOffice. К сожалению, это не гарантирует работу макросов VBA в LibreOffice. Чтобы макросы могли работать в обоих офисах, они должны быть адаптированы для этого.

В ряде случаев может помочь вот это средство конвертации: http://www.business-spreadsheets.com/vba2oo.asp

  • LibreOffice неожиданно закрывается без сохранения данных. Восстановление документов не помогает.
Пока известно две основных причины падения LibreOffice:
  1. ошибка библиотеки MSVC, которая проявляется под Windows 7. Для начала, следует переустановить библиотеку. ftp://ftp/SPO/LibreOffice/TroubleSooting/
  2. Также может помочь отключение OpenGL, как это описано выше.
  • Как напечатать документ нажатием одной кнопки, чтобы не вызывалось окно параметров печати?

Кнопка непосредственной печати по умолчанию скрыта. Чтобы показать нужную кнопку, нужно кликнуть по панели инструментов (можно по кнопке «Печать») правой кнопкой мыши и выбрать из меню «Показать кнопки» показ кнопки «Печать непосредственно». Эта настройка активируется отдельно для каждого приложения, т.к. панели инструментов у каждого свои.

Работа с Directum

  • При копировании ссылки из Directum она отображается кракозябрами

По умолчанию, при копировании, текст вставляется в формате RTF. Очевидно, текст берётся из directum не совсем корректно — с неверной кодировкой.
Если вставлять в формате HTML, через меню «вставить как», то ссылка будет вставлена как нужно.

  • Почему не открывается одновременно два документа из Directum?
    При попытке открыть второй документ, он открывается сам после того, как я закрою первый. Если попытаться открыть несколько документов, то получается целая «карусель»
Для того, чтобы документы нормально открывались из Directum, нужно, чтобы на момент открытия первого документа, LibreOffice уже был в памяти. Наилучшим решением является установка специального флага в настройках LibreOffice:
  • Зайти в меню «Сервис»→«Параметры...»
  • В разделе «LibreOffice»→«Память» установить опцию «Запускать LibreOffice во время запуска системы».

В случае, если LibreOffice завершился аварийно, его нужно будет перезапустить вручную, чтобы снова активизировать «быстрый запуск». В случае переустановки или обновления LibreOffice, нужно проверить, установлена ли эта опция.

  • После закрытия документа в LibreOffice, Directum не даёт повторно открыть его на редактирование.

Поможет установка опции «Запускать LibreOffice во время запуска системы», как описано выше. (Это официальная рекомендация техподдержки Directum)

  • Я открываю на редактирование из Directum документ в формате RTF/DOC/DOCX. Как сохранить его в Directum в формате ODT (расширение odt, ods и т. п.)?

Для этого нужно этот документ сохранить с новым именем локально, а затем создать новую версию и загрузить из файла. Для этого нужно на документе в Directum кликнуть правой кнопкой и выбрать «Импортировать»→«Из файла», а затем загрузить новую версию из локального файла.

Копирование и вставка

  • Как вставить в LibreOffice объект, чтобы он открывался по двойному щелчку в соответствующем приложении.

«Вставка→Объект→Объект OLE...». Далее нужно выбрать тип объекта «Дополнительные объекты» и в открывшемся диалоге выбрать «создать из файла». Галку «в виде значка» устанавливать не нужно. При этом, вставленный объект будет нормально виден в MS Office, но, если файл сохранить в MS Office, для LibreOffice объекты будут потеряны.

  • Я копирую данные из MS Office, и у меня съезжает всё форматирование. Копирование занимает очень много времени

Не следует копировать данные из одного приложения в другое. Следует открыть все нужные файлы в LibreOffice и все действия выполнять в нём.

Печать

  • Как напечатать в файл формате PDF?

Через меню «Файл»→«Экспорт в PDF». Если необходимо выпустить документ для длительного хранения, нужно установить опцию «PDF/A»

  • Напечатать файл с примечаниями?

Через меню «Файл»→«Печать...», выбрать нужную опцию в выпадающем списке «Примечания».

Автозамена

  • Я хочу напечатать аббревиатуру типа ГКиП, а она принудительно исправляется на ГкиП. Как быть?
Так работает «автозамена». Действие последней автозамены можно отменить, нажав «Ctrl»+«Z». Если Вы постоянно работаете с аббревиатурами и автозамена начинает сильно мешать, её можно отключить следующим образом:
  • нужно зайти в меню «Сервис→Автозамена→Параметры автозамены...» и во вкладке «Параметры» убрать галку «Исправлять ДВе ПРописные буквы в начале слова».
  • автозамену можно можно выключить, убрав отметку в меню «Сервис→Автозамена→При вводе»

Экспортировать в PDF HTML TXT