Проект

Общее

Профиль

Вопросы по LibreOffice Writer

Общие вопросы

  • При создании нового файла, устанавливается шрифт Calibri 12, а я хочу, чтобы был другой, например, Times New Roman 14. Как сделать, чтобы сразу устанавливался тот шрифт, который мне нужен?

Нужно в меню «Сервис»→«Параметры...» в разделе «LibreOffice Writer»→«Осн. Шрифты» установить те шрифты, которые вам требуются. Теперь, при создании нового документа, будут автоматически устанавливаться именно эти шрифты.

  • Есть ли возможность автоматического формирования и рассылки писем по шаблону?

Да. См. «Сервис»→«Рассылка писем...». Подробности можно посмотреть в справке.

  • Не могу понять, как работает кнопка «Копировать формат» (кисточка)?

Кнопка «Копировать формат» копирует атрибуты ручного форматирования и добавляет их к выделяемому тексту. Если попытаться скопировать форматирования с текста, у которого ручного форматирования нет, и применить к тексту, у которого оно есть, то ничего не произойдёт. Чтобы убрать ручное форматирование, нужно выделить нужный кусок текста и нажать «Ctrl»+«M» или выбрать «Отменить форматирование» из меню «Формат».
По умолчанию, в последних версиях LibreOffice кнопка копирует только форматирование символа. Если нужно скопировать форматирование и символа и абзаца, нужно вставлять форматирование, удерживая нажатой клавишу «Ctrl». Если нужно скопировать только форматирование абзаца - «Shift»+«Ctrl»

  • Вставляю новую страницу. Как изменить формат новой страницы? Например, сделать страницу альбомной?

Новая страница вставляется с помощью "Разрыва". Разрыв является свойством элемента текста, такого как абзац или таблица. Тип разрыва указывается на закладке "Положение на странице". Также можно навести курсор мыши на саму пунктирную линию, обозначающую разрыв, и задержать, после чего появится треугольник выпадающего списка. В списке следует выбрать пункт "Править разрыва страницы...".

  • После обновления пропало меню "Регистр" по правой кнопке мыши

Воспользуйтесь комбинацией клавиш «Shift»+«F3».
Это только на первый взгляд в LibreOffice ничего не меняется, на самом деле разработчики постоянно его совершенствуют. В данном случае убрали пункт меню, который очень мало востребован.
Если зайти в меню «Сервис»→«Настройка...», то, повозившись на вкладке "Контекстные меню", можно настроить всё как угодно под себя. Настройки затем можно сохранить либо в редактируемом файле, либо в конфигурации вашего LibreOffice.
Но, всё-таки, удобнее использовать «Shift»+«F3».

  • При вставке текста из буфера обмена, возникает окно с надписью "Перед вставкой из буфера обмена документ должен быть классифицирован" и вставить содержимое не получается

LibreOffice позволяет классифисировать документы по уровням безопасности. Для этого используется панель "Классификация". Классификация, в частности, предусматривает ограничения на копирование информации из документа с более высоким классом безопасности в документ с более низким классом безопасности. Если целевой документ не имеет признаков классификации, то выводится соответствующее предупреждение и вставка блокируется.
Варианты решения:
1. Убрать классификацию для исходного документа. Для этого зайти в меню "Файл"->"Свойства" и на вкладке "Свойства пользователя" удалить все поля, имя которых начинается с "urn:bails:", после чего закрыть документ с сохранением.
2. При вставке данных из буфера обмена, вставлять текст как "текст без форматирования".

Автоматическая нумерация

  • Не могу справиться с форматированием нумерации. Есть способ, как сбросить все настройки и начать сначала?

Можно выделить кусок проблемного текста, или весь текст, и применить команду «очистить форматирование», по правой кнопке мыши. Эта команда стирает всё форматирование, выставленное вручную, но оставляет все настройки, связанные со стилями. Т.е., если есть нумерованный список, то он таковым и останется, а вот тип и размеры шрифта, отступы, и т.п., что настраивалось вручную, будет очищено. Как правило, после этого действия, не составляет труда привести текст в надлежащий вид буквально за несколько кликов мышью.

  • В таблице есть колонка, в которой автоматически проставлены номера. При открытии файла в LibreOffice Writer, ячейки оказываются пустыми.

Это ошибка в MS Word, которая не учтена в LibreOffice. На самом деле, ячейки таблицы не пустые. Просто у текста в этих ячейках установлен отступ, который отодвигает текст за границы ячейки. MS Word просто игнорирует отступы для нумерованных списков, если они находятся в ячейках таблицы.

  • Я удалил нумерацию, клавишей «Backspace», но теперь для абзаца я не могу установить расположение по горизонтали и отступы.

Если посмотреть внимательно, то видно, что в этом случае абзац по прежнему имеет атрибут «список» - кнопка на панели зажата. Нужно выключить этот атрибут, кликнув по соответствующей иконке в панели управления.

  • Формат цифр в автоматической нумерации отличается от ожидаемого.

Это связано с установкой стиля для нумерованного списка. Если кликнуть правой кнопкой в соответствующем абзаце и выбрать пункт «Маркеры и нумерация...» (или кликнуть на соответствующую иконку в панели управления), а затем перейти на вкладку «Настройка», там будет опция под названием «Стиль символа».
Если эта опция установлена «Нет», для данного уровня нумерации будет использоваться формат шрифта, соответствующий абзацу. Для его изменения, нужно выделить абзац и установить нужный шрифт.
Если в этой опции указано имя стиля, то нужно отредактировать шрифт для данного стиля. Также изменить шрифт можно, установив курсор перед номером списка и выбрав шрифт из панели управления или меню «Символы...» по правой кнопке мыши.

  • Открываю документ в формате RTF и не могу понять, как отформатировать нумерованный список.

Дело в том, что при сохранении файла в формате RTF, всё форматирование сделано через «стили». Соответственно, документ содержит огромное количество стилей, применяемых к различным элементам текста по любому поводу. Чтобы форматирование было более-менее адекватным, нужно правильно менять стили для соответствующих элементов текста. Также нужно обращать внимание, что, казалось бы, один и тот же нумерованный список может оказаться разбитым на несколько отдельных списков. Проверить это можно, установив курсор перед номером. Подсвеченные номера будут соответствовать одному и тому же уровню иерархии в одном и том же списке. Если список в файле на самом деле разорван, то автоматическая нумерация в этом месте будет работать не так, как ожидается.

  • Автоматическая нумерация установлена для первой колонки в таблице. Если я объединяю ячейки в первой колонке, автоматическая нумерация пропускает столько ячеек, сколько оказались скрыты при объединении.

Если файл сохраняется в формате ODT, то при повторном открытии нумерация будет правильная. Если файл в формате DOC или DOCX, строки будут пропущены.
Это официально зарегистрированная ошибка в LibreOffice Writer.

Работа с таблицей

  • Как вырезать таблицу?

Если выделить таблицу или её часть, а затем попытаться вырезать, сама таблица всегда остаётся, вырезаются только данные из ячеек. Если потом вставить таблицу в новом месте, то скопированный текст вставляется как таблица.
Однако, таблицу можно вырезать целиком, если выделить её, вместе с окружающим текстом.

  • Как выделить таблицу, вместе с текстом?

Таблицу можно выделить вместе с текстом только если и перед таблицей, и после неё существует абзац. В этом случае, таблицу можно выделить, вместе с соседними абзацами.
Если таблица стоит в самом начале текста, абзац можно добавить перед ней, если поставить курсор в первую позицию первой ячейки и нажать «Enter». Это работает только в случае, если таблица находится в самом начале текста или после разрыва.
Замечу, что этот абзац будет иметь стиль «основной текст», у которого стоит интервал 0.25 см после абзаца.

  • Если я копирую ячейки из таблицы, а затем вставляю в другую, то, вместо данных в новых ячейках, вставляется новая таблица в ячейку, где стоит курсор.
В случае, если требуется вставить данные одной таблицы в другую, Writer ведёт себя следующим образом:
  • Если курсор стоит в первой позиции ячейки, то данные будут вставлены в эту ячейку и следующие ячейки вправо и вниз, если они существуют. Таблица вправо расширена не будет. Если не хватает строк, таблица будет расширена вниз.
  • Если курсор стоит не в первой позиции ячейки, таблица вставляется как вложенная.
  • Как из Calc вставить данные в таблицу Writer?

Единственной возможностью вставить значения таблицы Calc в таблицу Writer, это специальной вставкой вставить её как RTF, а затем уже переносить значения, как это описано выше.
Если вставить таблицу, скопированную из Calc, сразу после таблицы Writer, то можно воспользоваться функцией из меню «Таблица»→«Объединить таблицу», при этом объединённая таблица будет иметь формат той таблицы, в которой стоял курсор, при запуске этой операции.

  • Как удалить таблицу?

Кликнуть на таблице правой кнопкой мыши и выбрать «Удалить»→«Таблицу», либо воспользоваться командой из меню «Таблица».

  • Как сделать так, чтобы две строки таблицы не оказались на разных страницах?

Только принудительно разбив таблицу перед первой строкой. Пока так.

  • Как сделать так, чтобы строка таблицы не переносилась на следующую страницу?

В меню «Таблица»→«Свойства таблицы...» выбрать вкладку «Положение на странице». Обращаю внимание, что свойства в LibreOffice устанавливаются для таблицы целиком. Для отдельной строки свойства установить нельзя.

  • Как выделить цветом ячейку целиком?
    Я нажимаю кнопку «цвет фона» на панели «таблица», а цветом заливается абзац, а не ячейка.
Кнопка работает следующим образом:
  • если курсор просто стоит в ячейке, то цвет фона применяется к абзацу;
  • если выделена целиком ячейка или несколько ячеек таблицы, цвет применяется к выделенным ячейкам;
  • если выделена целиком строка таблицы, цвет применяется к строке.

Посмотреть, цвет ячейки или строки можно в меню «свойства таблицы» на вкладке «Фон».

  • Как выделить целиком ячейку таблицы?
  • С помощью мыши сделать протяжку левой кнопкой на нужное количество ячеек. Чтобы выделить только одну, нужно сделать протяжку за её пределы и вернуться обратно;
  • По правой кнопке меню в подменю «Выделить»;
  • Добавить кнопку выделить «Ячейку» в настройках панели инструментов «Таблица».
  • В таблице установлено разрешение на разбиение таблицы и строк между страницами, но стока всё равно не разбивается, а переносится целиком

Проверьте размер строки по высоте. Если нет необходимости, установите "оптимальная высота строки". Фактически, Writer пытается сделать строку именно того размера, как установлено в параметрах, и разместить её на странице. Если установлена отметка "подбор размера", Writer будет автоматически раздвигать строку, чтобы поместился весь текст.

Номера страниц

  • Как вставить или изменить номера страниц?

Номера страниц устанавливаются в «колонтитулах». Вставить или редактировать колонтитулы можно либо через меню «Вставка»→«Верхний колонтитул» («Нижний колонтитул»), либо кликнув мышкой в нижнем или верхнем поле страницы. Колонтитулы устанавливаются для соответствующего стиля страницы. Колонтитул форматируется точно также, как и текст на странице с тем лишь отличием, что этот текст будет появляться на всех страницах соответствующего стиля.

Различные номера на первой и последующих страницах, либо различные номера на правых и левых страницах, задаются с помощью соответствующих стилей, присваиваемых страницам. Чтобы правые и левые страницы чередовались, в свойствах стиля указывается поле «Следующий стиль», с помощью которого указывается, какого стиля будет следующая страница. Соответственно, в стиле «Первая страница» следующим стилем будет «Левая страница», в стиле «Левая страница» – «Правая страница», а стиле «Правая страница – «Левая страница».
Также, в стиле странице можно снять галку "одинаковые колонтитулы на первой странице", тогда колонтитулы для первой и последующих страниц этого стиля будут отличаться. Однако, при попытке удалить колонтитул, например, на первой странице, он удалится и на всех страницах этого стиля.

  • Почему после девятой страницы все остальные страницы имеют номер "1"?

На самом деле не все а только десять, потом будет "2", "3" и т.д.
Причина в том, что MS Word вставляет номера страниц в виде врезок в колонтитулы. Выравнивание текста во врезках и ячейках в MS Word и LibreOffice Writer немного отличается. Номер страницы просто не входит в предназначенную для него врезку и отображается только первая цифра.
Проще всего исправить ситуацию, просто удалив старый колонтитул и вставив его заново.

Рецензирование

  • Почему при рецензировании автор изменения или комментария указывается как <анонимный>?

Поскольку LibreOffice продукт кроссплатформенный, он не берёт информацию об авторе из операционной системы. Нужно заполнить параметры автора в меню «Сервис»→«Параметры» во вкладке «LibreOffice»→«Сведения о пользователе».

Экспортировать в PDF HTML TXT